Cuatro destellos en Sony KV-29AL40/8 | Laboratorio Electrónico // Fallas electrónicas resueltas

3 de agosto de 2011

Cuatro destellos en Sony KV-29AL40/8

Este televisor venia de otro taller en donde no pudieron resolver la falla original por la cual se los llevaron, con esto quiero decir que me lo entregaron con el mismo problema.

La falla de este televisor Sony modelo KV-29AL40/8, chasis BA-4 era que no encendía, solamente hacía el intento, y a continuación presentaba en el led de standby cuatro flash, destellos o parpadeos, con estas indicaciones el televisor estaba haciendo uso del autodiagnóstico que trae incorporado para podernos orientar de que lugar puede provenir el problema.

En la tabla de autodiagnóstico para este modelo, dice que esta falla es causada por problemas de alimentación en el circuito integrado de salida vertical IC541 o también este mismo integrado puede estar dañado, bastante fácil lo pinta la tabla y puedes decir pan comido.

Pues obedeciendo a estas indicaciones pude ver que en el otro servicio técnico (taller) le habían trabajado a la sección vertical e incluso le cambiaron el circuito integrado de salida vertical (V. Out) con número TDA8172 de 7 pines y nada, pero había un detalle extra con el FlyBack.

Pues hace mucho tiempo a este FlyBack le taparon una fuga de tensión con un pegamento epóxico y no quedó muy bien, porque dice el dueño que siempre se escuchaba pero en menor intensidad el escape de la corriente, pero así le trabajó un buen tiempo dijo.

Pero la fuga de voltaje había regresado con mas intensidad antes de que se le arruinara el televisor, y todo esto hizo que en el otro taller dudaran del Fly, a tal punto que decidieron sustituirlo por otro que no era el original pero con el mismo numero o sea este: 8-598-998-00 y tampoco resultó, entonces tiraron la toalla y esta fue la historia antes de caer en mis manos.

Le pregunté al dueño que si cuanto le había costado este FlyBack y el me dijo que 6 dólares y fracción, con este precio dude de la calidad de este componente.
Bueno dejando atrás todo esto e ignorando la calidad entre comillas del FlyBack, empecé a hacer mi propio diagnóstico, y con mas detenimiento me di cuenta que el televisor aparentemente encendía y digo esto porque como sabrán estos aparatos llevan dos relay y cuando le daba power se escuchaba la activación simultánea de los dos e inmediatamente uno se desactivaba y era el RY601 circuito degauss o mejor dicho el encargado de desmagnetizar la pantalla en cada encendido, hasta este punto puedo decir que todo OK.

El relay RY602 (AC Power) que es el switch por donde entra la corriente alterna (AC) a la fuente demoraba como 8 segundos en desactivarse, a esto me refiero cuando dije que el televisor aparentaba encender, pues este lapso de tiempo permitía hacer mediciones y en especial me interesaba el B+, y si andaba bien ya que medía 134 voltios, porque dice el diagrama que tiene que medir 135 voltios pero con un margen de error o tolerancia de mas o menos 3 voltios.

También pude comprobar que el FlyBack hacía su trabajo porque se veía que el filamento del TRC encendía y también  medí tensiones de +13 voltios  y – 13 voltios en los pines 2 y 4 respectivamente en el IC de salida vertical TDA8172 y median dentro de los valores apropiados, en fin en el poco tiempo que me daba para hacer pruebas le hice muchas mediciones mas que todo en la sección vertical.

Pero para hacer todas estas pruebas me las tuve que ingeniar, porque el diagrama para este modelo no trae una tabla de voltajes que por lo general en la mayoría de esquemas de esta marca la traen, pues tuve que trabajar también con  un diagrama de chasis BA-5, mas que todo me interesaba saber los voltajes de todos los pines de TDA8172 y según esa tabla los valores andaban bien.

Al ver que todo parecía normal se me ocurrió mover el screen al máximo en el FlyBack, luego encendí y pude ver iluminación en pantalla pero luego se apagó, al descubrir esto volví a ajustar el screen a un nivel que yo calculaba correcto pues encendí y no dio nada en pantalla pero al apagarse inmediatamente lo encendí y otra vez nada, en el tercer encendido pude ver imagen, en el cuarto encendido pude regular screen al gusto.

Todo lo anterior de estar encendiendo y encendiendo para que me diera imagen hasta la tercera vez, me lo pude evitar si hubiese alimentado el filamento con una fuente externa para que cuando prendiera el televisor los tres cátodos en el cañón ya estuviesen calientes y por lo tanto pudieran generar los tres haces de luz RGB necesarios para ver la imagen.

En el tiempo corto que se mantenía encendido, la imagen se veía perfecta, con buen color, ningún problema de anchura horizontal o vertical o sea ningún detalle, hasta se podía cambiar canal y dar volumen y todo perfecto pero se apagaba.

Descubrir todo lo anterior me animó mucho más a insistir en la búsqueda del problema, pues me enfoque en los cuatro destellos y viéndolo bien tomé en cuenta que el pin 17 llamado I-PROT en el microprocesador  con numero M37273MF-251SP es el encargado de vigilar el buen funcionamiento en la sección vertical, mas exactamente el pin 17 tiene que estar recibiendo desde el pin 3 (REF) del TDA8172 un pulso de referencia de 60hz  y si esto no ocurre el televisor se protege y a la vez indica con los 4 parpadeos que el problema es detectado por el pin I-PROT.

En la línea que transporta el pulso de referencia vertical hasta el micro solamente hay dos componentes y son una resistencia de 10k (R549) y un diodo zener (D001) de 5.1 voltios que por supuesto los medí y ninguna novedad, pero al medir voltaje al pin 17 (I-PROT) del micro había un voltaje de 4.74 voltios, este voltaje no era correcto, ya que el valor correcto es de -0.2 voltios.

Esta anormalidad me hizo regresar a medir tensiones a la sección vertical y todo bien, pero también pensé: si la imagen esta perfecta en pantalla sin ningún detalle, es ilógico buscar el problema en vertical, lo que hice después de esto fue desoldar el pin 17 del micro, y ya aislado del circuito impreso le volví a medir tensión y siempre me midió los 4.74 voltios, pero también medí frecuencia al circuito impreso y si estaba presente el pulso de referencia de 60 hz.

Con este dato ya no quedaba duda que el problema era causado por el microprocesador y para terminar de comprobar esto, puse el tester en la escala de ohm y medí el pin 17 con el pin 27 (VCC) que es el encargado de recibir los 5 voltios con lo cual es alimentado el micro y estos me midieron 25.6 ohmios, o sea que I-PROT y VCC estaban casi prácticamente en corto y este era el motivo por el cual en I-PROT se mantuvieran los 4.74 voltios, ya sea conectado o no al impreso.

Detectado el problema se avecinaba otro y era que se buscó este micro M37273MF-251SP nuevo o usado y de ninguna manera se encontró, al tener esta nueva adversidad pude notar que el dueño del televisor prácticamente perdió la fe que su televisor volvería a la normalidad, entonces le dije que tuviera un poco de paciencia que talvez lo podía conseguir y así fue lo seguí buscando y nada.

Entonces me pregunté: ¿será que puedo poner un micro con otro número similar? y para satisfacer mi duda busque en Internet algún dato sobre esto y tampoco hallé nada, el paso siguiente fue bajar el datasheet de este micro y resulta que son varios los microprocesadores que pertenecen a esta familia de la marca MITSUBISHI MICROCOMPUTERS y son estos:

- M37273M8-XXXSP
- M37273MF-XXXSP
- M37273E8SP
- M37273EFSP

En la descripción pude entender que los números M37273M8-XXXSP y M37273MF-XXXSP son iguales y su única diferencia es su tamaño en memoria ROM y RAM o sea así:

M37273M8-XXXSP: ROM = 32K bytes y RAM = 1152 bytes
M37273MF-XXXSP: ROM = 60K bytes y RAM = 1472 bytes

Ya sabiendo todo esto encontré en mi huesera un M37273M8-204SP sabiendo que son iguales pero con diferencia en tamaño de memorias decidí probarlo y si trabajó, ya no se apagó, pero en pantalla no había imagen, parecía estar en video y solamente había OSD ya que podía ver cuando cambiaba canal, volumen y hasta se podía entrar a modo de servicio.

En modo de servicio intenté en algunos parámetros activar el video y nada, hasta moví los option bytes para ver si obtenía resultados y tampoco, con todas estas pruebas comprendí que ese micro no iba a funcionar adecuadamente y ya casi abandonaba la idea de probar con otro número de micro, pero no me rendí y en huesera encontré una placa de chasis BA-5 creo, que por suerte yo no había querido botar.

La historia de esta placa es que ya tiempos me llevaron a reparar un Sony de 21” que tenía tiempos de estar arruinado y lo habían dejado a la intemperie y le cayo agua lluvia, ya se imaginarán como estaría la placa, pues si tienen razón estaba toda corroída y era irreparable, entonces me lo regalaron pues boté todo y guardé la placa nada mas.

Esta placa tenía un micro con número M37273MF-255SP pero estaba bastante corroído, que la verdad dudaba que estuviera bueno, pero igual lo extraje, le raspé sus pines y lo lavé con jabón, quedó bien limpio luego procedí a ponerlo y a cruzar todos los dedos.

Encendí el televisor y lo hizo casi a la perfección, ya que me dio buena imagen y buen sonido, solo detecté un detalle y era que no auto-programaba los canales y era porque al hacer un cambio de canal no los enganchaba o sintonizaba a la primera, hacía un leve parpadeo o salto antes de engancharlo definitivamente y a este salto le atribuía que no pudiera auto-programarlos y pensé que talvez nesecitaría algún retoque en el modo de servicio.

Entré al modo de servicio con: display - 5 - volume (+) - power  y busqué algún parámetro referente a AGC o a AFT y no halle nada en especial, aunque moví algunos y nada de resultados, entonces encontré un parámetro llamado HCHM que la verdad no se que significa y busque su significado en la lista de parámetros que aparece en el esquema de este chasis y no esta en esa lista, ahí deduje que estos micros traen grabados en su memoria ROM (memoria de solo lectura) los parámetros para cada chasis, pues le hice unos cambios a este parámetro y tuve suerte porque con eso los canales ya no hacían ese salto y ya se podían auto-programar.

Así que ahora puedo decir que el M37273MF-251SP y el M37273MF-255SP son compatibles y para que vean que es cierto en la imagen pueden ver el numero de micro que aparece en la pantalla del televisor, gracias a esto el cliente quedó muy complacido con su televisor reparado.

El diagrama, plano, esquema, manual de servicio o como lo llames lo puedes bajar o descargar gratis desde este enlace.

Reconozco que con este tema me extendí demasiado pero era muy difícil para mi explicar todo lo expuesto en pocas palabras, así que espero no haberte aburrido si tuviste el valor de leerlo todo, gracias y hasta luego.

PD: Se me olvidaba decir que ese Fly Back barato quedó definitivamente trabajando en el televisor porque después de probarlo bastante no dio ningún inconveniente (si leyeron el tema completo sabrán a que me refiero)

9 comentarios:

  1. Mi estimado amigo,Me presento Como cibirama y estoy en Acapulco Mex.
    Me intereso Mucho este articulo porque nos llevaste de la mano en toda la lucha. Y te lo agradesco de corazon. La manera de ir explicando me da la impresion de que eres una persona dedicada y con mucha nobleza. Otra vez gracias.

    ResponderEliminar
  2. Hola cibirama, gracias por tu comentario, hasta luego.

    ResponderEliminar
  3. me parecen muy estupendos tus comentarios y logicamente tu blog
    muy pero muy bueno, tengo un dvd sony modelo DVP-NS 575P quisiera que con tu experiencia me ayudaras a desbloquiarlo para multizona enviandome la forma de hacerlo mi nombre es Bernardo cabrera reyes soy de ataco tolima Colombia mi correo becare1234@hotmail.com .le estare muy agradecido

    ResponderEliminar
  4. Hola Bernardo, la verdad no se como se pueda volver multirregión ese modelo de DVD, lo único que te puedo decir es que en internet hay mucho sobre ese tema algunos metodos parecen faciles y otros mas complicados y te dejo un enlace en donde puedes ver varias formas que podrías probar, unas en ingles y otras en español, entra aquí.

    Con respecto a este comentario hubiese sido mejor que lo hicieses en un post mas adecuado al tema así como este:

    DVD con Imagen fuera de sincronía.

    Gracias por la confianza y también gracias por tu comprensión.

    ResponderEliminar
  5. Viejo, te escribo desde México. He leído y seguido todos tus pasos pues tengo un TV KV-25FV10 y también me ha dado bastante problema. Pero ahora me has dado luz y he medido la resistencia entre las patas 17 y 27 de mi M37273MF-253SP fuera del impreso y me manda 43 ohm. Supongo que es el mismo problema, así que ahora me daré a la tarea de cambiar el micro. Espero encontrar uno semejante. Muchas geacias por el post, saludos. M. Palomino.

    ResponderEliminar
    Respuestas
    1. Que bueno colega que te ha servido el dato, saludos y suerte

      Eliminar
  6. Amigo tengo el mismo problema con tus indicaciones voy a tratar de repararlo pues el caso es muy parecido al suyo gracias de antemano

    ResponderEliminar
  7. hola,tengo un sony chais ba4 de 29pulg es el kv-29sl40 y me hace una distorsión en el barrido vertical, no me parpadea el led en ningún momento, a su vez cuando aparecen en la imagen (de los canales)alguna leyenda, la imagen se distorciona en esa parte (no toda)en forma de zigzag. no tengo idea que puede ser, tenés alguna idea? gracias x tu tiempo , un abrazo desde uruguay

    ResponderEliminar
  8. Hola amigo Qué interesante es ver cómo te dedicas tanto a un televisor lo felicito te hablo desde Colombia Me gustaría saber si recuerda los voltajes del tda 8172 Tengo un problema de salida vertical de un televisor pilot esto es marca China por tal motivo no encontrado diagramas de y me gustaría saber en dónde está la falla nada que me quema la resistencia sólo me abre media pantalla y pues Te agradecería si me pudieras regala los voltajes de este integrado De antemano muchas gracias y que Dios te bendiga.

    ResponderEliminar